IPB

Здравствуйте, гость ( Вход | Регистрация )

 
Reply to this topicStart new topic
> патч Warcraft 1.24a, + Dota Allstars 6.61c
KpAcTu
сообщение 12.8.2009, 19:55
Сообщение #1


Активный участник
***

Группа: Пользователи
Сообщений: 140
Регистрация: 16.3.2009
Из: сумрака.
Пользователь №: 12



ОБНОВЛЕНИЕ 1.24

ИЗМЕНЕНИЯ В РЕДАКТОРЕ МИРА

В продвинутом редакторе триггеров (JASS) добавлены новые функции хэш-таблицы, чтобы компенсировать потерю функциональности в связи с исправлением небезопасной конвертации типов переменных

Хэш-таблица — сохранить ссылку на предмет

Хэш-таблица — сохранить ссылку на боевую единицу

Хэш-таблица — загрузить ссылку на предмет

Хэш-таблица — загрузить ссылку на боевую единицу

Хэш-таблица — получить ID ссылки

ИСПРАВЛЕНИЯ

Устранена уязвимость, связанная с небезопасной конвертацией типов переменных, которая позволяла выполнение произвольного кода в картах

Устранена уязвимость в JASS, связанная с небезопасной конвертацией типов переменных («ошибка возвращения»)

Исправлены несколько ошибок, приводивших к сбою в работе редактора.

UP: Компания Blizzard выпустила очередной патч к Warcraft III - 1.24. Как и в случае с 1.23 изменений в балансе нет, но исправлено несколько серьезных уязвимостей, позволявших злоумышленникам исполнять произвольный код на компьютерах игроков с помощью специальным образом настроенных пользовательских карт. Также, из-за того, что некоторые потенциально опасные функцииJASS(встроенный в Warcraft III скриптовый язык программирования) были заменены на безопасные аналоги, большинство популярных пользовательских карт отказываются работать на новом патче, в том числе и последние версии dota allstars. В связи с этим, Icefrog рекомендует дождаться выхода патча 1.24b и новой - 6.62 версии доты, по его словам эта связка должна работать нормально.

Комментарий Icefrog'a:

Мне задают очень много вопросов про 1.24 и доту, поэтому я разом решил ответить на них.

Новый патч к warcraft'у был выпущен прежде всего для того, чтобы исправить баг, из-за которого можно было заразить компьютер вирусом, скачав пользовательскую карту. Как результат, некоторые основные функции warcraft'а, которые используются в доте и большинстве других карт, были удалены. Чтобы заменить столь значительную потерю в функциональности, в патче были добавлены функции-заменители.

Путаница возникает из-за того, что некоторые карты, например 6.59d, работают под 1.24. Но это только частично правда. Нет ничего удивительного в том, что 1.24 временно настроен запускать некоторые карты в режиме совместимости с 1.23, пока 1.24 дорабатывается. Но патч не был должным образом настроен для того, чтобы запускать 6.61b в режиме совместимости, поэтому будет выпущена версия 6.61с, в которой не будет никаких изменений, кроме индекса версии.

Из-за изменений в функциях, карты не обладают обратной совместимостью с бета версией 1.24. Очень много кода необходимо переписать, чтобы сделать карты совместимыми с 1.24. Следующая версия доты(6.62) будет переписана для соответствия требованиям 1.24.

Даже сейчас в функциях 1.24 все еще остаются различные баги, препятствующие нормальному запуску карт на нем. Как только эти проблемы будут исправлены в предстоящих патчах 1.24b/1.24c, бета версия 6.62 будет обновлена в соответствии с ними. Как только новый патч обретет стабильность, и 6.62 будет достаточно протестирована, она будет выложена для всеобщего скачивания. Надеюсь я приведу карту в порядок в ближайшем будущем.

Как только ситуация с 6.62/1.24 разрешиться, я вернусь к обычной доработке карты. В следующих версиях упор будет делаться на улучшениях баланса и производительности.

Людям, которые не могут легко менять патч(например, пользователям интернет кафе), я рекомендую дождаться 1.24b/с перед тем как устанавливать патч.
P.S. Версия Dota Allstars 6.61c, совместимая с 1.24

Источник UP : prodota.ru


--------------------
Стремлюсь всем людям помогать, но в рот я вас хотел е*ать!
Роги настолько суровы что им не нужны советы как и кого убивать
My sword will punish you in a shade.



Бой против роги:
Вы не можете этого сделать потому что вы – Оглушены
Вы не можете этого сделать потому что вы – Оглушены
Вы не можете этого сделать потому что вы – Оглушены
Вы не можете этого сделать потому что вы – Оглушены
Вы не можете этого сделать потому что вы - Мертвы
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 



Текстовая версия Сейчас: 3.12.2020, 2:10